Make a game with Hoot for the Lisp Game Jam!

Hey everyone! The Spring Lisp Game Jam is starting this Friday, May 17th and we’d like to encourage people to try using Hoot to make HTML5 games! All the details are in our new blog post so check it out for more info.

1 Like

I’ve been trying to use your template on Debian by compiling my own guile (v3.0.9) and guile-hoot (HEAD). I’ve written this script named guile:

#!/usr/bin/env bash
SCRIPT_DIR=$( cd -- "$( dirname -- "${BASH_SOURCE[0]}" )" &> /dev/null && pwd )
"$SCRIPT_DIR/pre-inst-env" "$HOME/code/guile/guile-v3.0.9/bin/guile" "-L" "$HOME/code/git/guile-hoot "$@"

which invokes pre-inst-env from guile-hoot.

What I do is export PATH="$my_guile_dir:guile-v3.0.9/bin:$PATH" so that it grabs v3.0.9 guild but also uses my guile bash script for guile.

Although unrelated, for convenience I’ve also added a .dir-locals.el with

((nil . ((geiser-guile-binary "$my_guile_dir/guile"))))

However, running your template’s make fails because guild complains that the compile-wasm script is missing.

Any ideas? I see compile-wasm under module in guile-hoot but I’m not sure how to tell guild to pick it up.

I think I need to mess with all the GUILE_LOAD and HOOT_ environment variables myself to get it working. I’ll post back after trying this.

Edit:

Oh yeah I just added an activate script that exports all the relevant GUILE_ and HOOT_ variables and now it’s working! As for invoking guile (geiser) from Emacs, I wrote another script that first sources the activate script and then passes to guile, and that’s what my .dir-locals.el is pointing to.

1 Like

Hi, I’m trying to set up the game template, and when I run guix shell, I get back error: guile-hoot: unbound variable; hint: Did you forge a 'use-modules' form?

I’m new to Scheme/Guile, so I’m not sure what information you might need. I installed Guix from their install script on Fedora 38, if that helps.

1 Like

Hi @jcarvajal288, I think the Guix you installed is just a bit old. Guix is a rolling release distro and moves quite quickly. To update, run guix pull. When it completes, run hash guix just to ensure that your shell notices the updated executable. To test if all is well, run guix show guile-hoot to make sure it knows about the package. Make sure that you’re seeing Hoot 0.4.1 in the output. You should be able to use guix shell after that. Hope this helps!

That worked; the game is running! Thanks for your prompt reply.

1 Like